New Software Release - Preview Build 54

Hi Batrium Community!

We’ve just released a new version of our ToolKit2 software and accompanying WatchMon firmware. Version 54 includes:

  • Firmware improvements that will improve your experience on our new iPhone and Android apps
  • Streamlined the web provisioning for adding devices to BMI WebAccess
  • Resolved WIFI network stability on some devices with dropouts that were unable to reconnect or fetch IP

As always, you can find this latest release on our Software page:

All the best with your battery projects, and don’t hesitate to post your wins or issues in your own topic here :slight_smile:

After installing version 54, Wi-Fi connection fails. So far it has been running for 4 years without any problems. With the 54 I configure the Wi-Fi and after a short time the connection is lost and cannot be recovered…….

Hi Javier,

Sorry to hear you are having troubles, and that your reply slipped under our radar!

We did make some changes to how WiFi connects for 54, but these actually improved things in our test rather than hurting them.

Could you confirm you’ve updated the firmware of your WatchMon, and tell us what the signal strength of your access point?

Does your AP broadcast on 2.4GHz and 5GHz simultaneously on the same SSID?

Keen to get to the bottom of this for you :slight_smile:

I’ve got the same problem.
And yes the firmware has been updated.

If I power cycle the WatchMon I can connect ok for a few days, maybe a week, then it drops off.
WiFi is both 2.4 & 5GHz, signal strength I can’t check right now but from memory was good (devices are about 5m from each other).

Happy to help out with some logs etc but I won’t be in front of the device for a few days.

Hi James
My wifi is 2.4Ghz and 5Ghz. Until now it was working well. I have had to change the Wi-Fi to create 2 different networks and it works fine, but for my needs this is a problem. I would like to be able to maintain a single network name with the 2 frequencies like I had before. I hope this is fixed in future versions…

Hi Javier

It seems when your router hosts 2.4 and 5 simultaneously, it does not broadcast it’s SSID on 2.4GHz. This means your network will not show up on our list, but you can still connect to it.

Just carefully enter the SSID into the field of the Join WiFi AP tool and it should work,

Let me know if you have any troubles.

Had Wifi problems with previous builds, it got worse over time. First dropouts every few weeks, than days. With the lastest beta dropouts every few hours. Sometimes it looked like the connection dropped when suddenly the sun came out and a high load on the batt.

Added a stable powersupply to the WM5, it was running from the 48V batt before. No change
Set up a second 2.4 only wifi (with my 5Ghz AP) (15m away), no change
Bought a shelly to remotely switch on/off the WM5
Set up a new 2.4 wifi with a different old AP 2m away from the WM5, dropouts again
Connecting to my Wifi was not easy, several errors when trying to connect, sometimes it worked within 2 seconds, then 5-10 seconds, or an error.

Then tried another newer AP, again only 2m away, that seems to have solved the problem, works now for > 1 week without issues. The WM5 seems to be very picky which AP it likes or not. All other clients (including several Raspis next to the WM) never had issues

1 Like

Finally the wifi has failed again, it has been working for several days and it has failed again. Do you have a reliable version that guarantees that I will not have problems?

It’s called band-steering and is an option on many access points to try and move clients to 5GHz. It is not causing a problem for me; however, you can try disabling it to see if it helps.

1 Like

Has anyone got a link to the software from somewhere else?

The download link continues to be faulty on the batrium page, even when copying and pasting the link

Oh really? I still have no answer on this matter…
We are talking about a Wi-Fi connection, something basic. I have not been able to connect to the system for several days because the Wi-Fi has not connected since the change to version 54. Since I am remote I cannot use the Wifi AP join function. Can you guide me, give me any solution? This forum doesn’t seem very agile…

Ill be honest when i upgraded a few months ago and tried the WiFi feature i didnt find it to be very good, also it prevented the BMS from using the serial connection. So i do not use WiFi or the APP.
I instead run a mini PC with the toolkit next to the BMS and the mini PC is online and remotely accessible. this is how i manage it

I have this problem as well albeit a different circumstances.
When web broadcast is enabled, it causes CAN communication dropouts. This dropouts result in CAN communication error on the inverter and the power goes off momentarily. This started when I updated to build 51.
However, with build 54, there is a new problem. When the power goes off and back on, the Wi-Fi disappears and the toolkit software goes offline until I restart the watchmon core. I have to disable web broadcast to make it work properly.

hi all, same challenge here. I have to do the “Join wifi AP” every 3days. Hopefully something will be done.

Just another case of WiFi issues here, just unboxed a new WMC and updated the firmware to 54 and the WiFi won’t stay stable for more than a few minutes.

My network is 2.4Ghz only so no band steering or mixed SSID issues here.

SOLVED: Leaving this here for others. There is a bug that if you are connected to the WiFi access point the WMC creates AND try to connect it to another WiFi access point then WiFi fails.

DEVS, the onboard AP should be disabled if the WMC is connected to another established network/AP.

1 Like

This is the intended functionality and how it will work in 55.

I’m sorry to hear the WiFi changes in 54 are a bit of a backstep for now. I’m pushing hard to get this fixed in 55 alongside the other critical CANBUS stability improvements.

Hello, I also have a problem with the WiFi connection.
Every few days (irregularly) the WiFi connection stops and can no longer be connected even without restarting Batrium. I’m using version .54.
Is there a workaround or solution? Use the WiFi connection for the WatchMonToolkit and tracking in Home Assistant.
In the earlier versions it worked without any problems.

Hello, why don’t I get an answer? The problem occurs daily, sometimes every 2 hours! From what I read here, I’m not the only one with the WLAN problems. Ts there a solution? What is the status of finding a solution? Is it possible to downgrade and does that help?
Thanks for your answer/update

Hi, htom89, we have been hard at work fixing up WiFi and stability in our upcoming build 55. Sorry I didn’t see your initial post.

In the short term, you can downgrade your software and firmware by:

  • Uninstall ToolKit2 and reinstall an older version
  • Use “Force Override” in the firmware update tool to allow the firmware to go backwards.

Once 55 has been released, we are confident you will see much better WiFi stability, more than older versions.

1 Like

Hey James,

any estimates on when you will release v55?