Canbus disconnect when wifi is used

Wifi connection can not be used. I had an ASUS router ACxxxx that worked fine with batrium. After a Asus firmware update to the router and over a few weeks the CANBUS comunication would randomly drop between growatt and watchmon core and progressively increased drop intervals. I didn’t realize at the time that the interference was from the wifi. I updated my cables to completely shielded between mppt and watchmon, reconfigured constantly to see if anything changed, verified all settings, scoured internet topics and was about to give up on batrium until by chance i moved the router slightly and the frequency of disconnect increased drastically (every 30 seconds or so).

I purchased a brand new ASUS RT-AC5300 router, still not realizing the issue happened with firmware update. After hookup everything worked perfect… After about 5 weeks i decided i should upgrade firmware on router for better security protocols. Before the router had finalized the update the communication on canbus dropped and power was cut. This was my ah ha moment remembering i had updated the previous router firmware too. I connected an old wireless netgear N router and the connection was good and canbus uninterrupted as long as the netgear was not connected to the ASUS or internet.

Now, i cant even connect to any router. So no remote monitoring at all.

This is my set up in a nutshell:
2x growatt lvm 3000 running in split phase
Batrium watchmon core with 3x k9 units
Three banks @ 7s each, 29.2v max. Approx 1090 AH
can bus connection: can use either 28 reserved or pylontech emulator. Im using pylon tech which is Growatt protocol 52. (I have used 28 reserved with growatt protocol 51 with no difference in problem)

My cable from watchmon to host inverter is a Shielded cable with ground wrapper/wire connected on watchmon side only.

The system runs perfect as long as i dont look for or connect to any router.

Thoughts? Ideas? I believe its a defective board but havent gotten helpful results from batrium support.

These are things I would try myself on wifi side:
decrease the routers radio power
downgrade the firmware on the old router
convert the old router to an access point
change wifi channles to see if interference goes away
investigate is interference is on watchmon side, or on inverter side

Hi @NickASmith2015 can you verify if you were able to check these WiFi troubleshooting steps outlined in our Wiki?

If nothing helped, please direct it to our team at so we can help and further investigate the issue.